CVE-2018-8828 - Kamailio 5.1.1 / 5.1.0 / 5.0.0 Heap Overflow

Kamailio versions 5.1.1, 5.1.0, and 5.0.0 suffer from an off-by-one heap overflow vulnerability

https://nvd.nist.gov/vuln/detail/CVE-2018-8828

https://github.com/EnableSecurity/advisories/tree/master/ES2018-05-kamailio-heap-overflow

This vulnerability was discovered during an exercise with Sandro Gauci of Enable Security