Asterisk 15.2.0 chan_pjsip INVITE Denial Of Service

Asterisk running chan_pjsip suffers from an INVITE message denial of service vulnerability. Versions affected include Versions affected include 15.2.0, 15.1.0, 15.0.0, 13.19.0, 13.11.2, and 14.7.5.

https://github.com/EnableSecurity/advisories/tree/master/ES2018-04-asterisk-pjsip-tcp-segfault

This vulnerability was discovered during an exercise with Sandro Gauci of Enable Security